Page 1 of 1

Submitting News doesn't post to the frontpage anymore

PostPosted: Fri Apr 25, 2008 4:23 pm
by Spoff
I've been using Coranto for years now and for the first time I had an issue today. I do a standard post and submit it and it doesn't make it to my frontpage and I get the following error.

"Unable to open /usr/www/virtual/ Permission denied at /www/virtual/ line 281"

When I check my news folder there isn't even a ndtmp1 text file?!?!

Any help would be great.


PostPosted: Fri Apr 25, 2008 6:52 pm
by driv
This happened to me once when I double submitted news (or was that modified news?) Anyway it deleted my newsdat file and gave me the same error as you.

Restoring newsbak got things up and running again.


This post suggests that the server may be low on space... ... ght=ndtmp1

Also this one... ... ght=ndtmp1

PostPosted: Fri Apr 25, 2008 7:39 pm
by Spoff
Can I just rename the newsbak1.txt file to newsbak.txt?

PostPosted: Sat Apr 26, 2008 2:08 pm
by driv
Rename newsbak1.txt to newsdat.txt

There is also an older backup available called newsbak2.txt

PostPosted: Sat Apr 26, 2008 3:25 pm
by Spoff
OK great I will do that now. Then a full rebuild I assume?

PostPosted: Sat Apr 26, 2008 6:26 pm
by driv
Yes and that will create the new backup files as well :)

PostPosted: Sat Apr 26, 2008 6:48 pm
by Spoff
Well I did as you suggested and I am getting the exact same error still when I attempt to submit or modify any posts. Any other suggestions for me to try?

PostPosted: Sat Apr 26, 2008 10:01 pm
by driv
ok - did you check the permissions of the news directory?

Also, what about the permissions of the files inside?
I know that on some hosts I have been with, the permissions have changed 'mysteriously' even though the host denies it!

I should have suggested this first :roll:

PostPosted: Sat Apr 26, 2008 10:48 pm
by Spoff
The news folder is 755 and the files inside appear to be 644.

PostPosted: Sun Apr 27, 2008 8:46 am
by driv
Just for the purposes of testing, can you make them both 777 - just temporarily.

If it still doesn't work, put them back as they were.

PostPosted: Sun Apr 27, 2008 3:42 pm
by Spoff
Ok I changed the news folder to 777 and tested a posting and got an error for news.txt. I changed that file to 777 also and everything is working again. One last question I have is "Does this open me up to any security flaws or attacks?"

Thanks A TON by the way, great help!!!

PostPosted: Sun Apr 27, 2008 7:21 pm
by driv
It's best to make things as restrictive as possible.

If you can reset the folder to 755, then try 666 or whatever for the text file.

I can't see any way that newsdat.txt being open could compromise you (although I am happy to be corrected on this) - the only thing I can think of is that the file could (theoretically) be overwritten as it's wide open.

Usually this sort of attack only happens to file named index.* or config.* as the perpetrators are usually scriptkiddies.