Page 1 of 1

Auto-Build settings suggestion

PostPosted: Sun Jan 21, 2007 5:06 am
by Dale Ray
Make the auto-rebuild setting work on a per profile basis.

Change the main setting to ON, OFF, Per Profile

If the setting is Per Profile the user sees a setting on the profile settings page for Auto-Rebuild ON or OFF.

For the most flexibility you would probably need a setting for the default value.

PostPosted: Sun Jan 21, 2007 6:31 pm
by Musicvid
Would love to see autobuild per profile in the Dev release.

PostPosted: Mon Jan 22, 2007 8:36 am
by Lumberjack
Hmm, ok.. will take a look. Maybe it can be in the form of an addon, if its easier.

PostPosted: Mon Jan 22, 2007 9:00 am
by Gilbert
Lumberjack wrote:Hmm, ok.. will take a look. Maybe it can be in the form of an addon, if its easier.


There was one even two if I recall well

PostPosted: Mon Jan 22, 2007 9:20 am
by Lumberjack
Anyone remember the names, then? It would be easier to just get those working in dev.

PostPosted: Mon Jan 22, 2007 10:40 am
by Dale Ray
I think that the addons that Gilbert wrote about were Partial Build and Extractor. These do not autobuild on submission or modification.

PostPosted: Mon Jan 22, 2007 10:45 am
by Gilbert
Dale wrote:I think that the addons that Gilbert wrote about were Partial Build and Extractor. These do not autobuild on submission or modification.


Thanks Dale. I was trying to root out the names as I do not have them installed any-longer (If I recall they were causing me grief when used more than anything else. Basically resorted to use the full rebuild)

PostPosted: Mon Jan 22, 2007 3:04 pm
by Lumberjack
I guess its probably something as simple as checking:
Code: Select all
if $Profile{$autobuild} { **do build** }

It could be a fairly easy job..