Archiving giving me a strange error

All notes and input on 2.0 Development are herein. <ul><li>Feature requests</li>
<li>Bug Reports</li>
<li>Beta Testing Feedback</li>
<li>Open Dev Discussion</li></ul>

Moderator: Coranto Moderator Team

Archiving giving me a strange error

Postby bozoka45 » Thu Dec 09, 2004 11:01 am

I'm trying to get archiving to work in Coranto 1.30.8. I'm not sure if its just that version, so I'll post it here first.

I only get this error when I use single field archiving for the news (the undeletedable profile).

Here is the error I get:

Unable to open /. Is a directory at crcore.pl line 297.


And here is the stack trace, if it'll help.

(eval) in coranto.cgi, line 35
main in coranto.cgi, line 39
RunCoranto in coranto.cgi, line 67
PageHandler in crcore.pl, line 132
GenHTML in crcore.pl, line 150
BuildNews in (eval 14), line 5
CRopen in (eval 15), line 518
CRdie in crcore.pl, line 323
User avatar
bozoka45
 
Posts: 1159
Joined: Sun Mar 23, 2003 8:38 pm
Location: New Orleans

Re: Archiving giving me a strange error

Postby Parahead » Thu Dec 09, 2004 2:44 pm

bozoka45 wrote:I only get this error when I use single field archiving for the news (the undeletedable profile).

Here is the error I get:

Unable to open /. Is a directory at crcore.pl line 297.
And you have specified a Archive File Path for the Profile or a default archive file path under the general settings page?
Yes, I am still around...
www.parahead.com/coranto/
User avatar
Parahead
 
Posts: 4837
Joined: Fri Jan 12, 2007 8:54 pm
Location: Stockholm - Sweden

Re: Archiving giving me a strange error

Postby bozoka45 » Fri Dec 10, 2004 12:18 am

Parahead wrote:And you have specified a Archive File Path for the Profile or a default archive file path under the general settings page?


Either method returns the error. If I change it to something besides single file then it works (month, day, week, etc).
User avatar
bozoka45
 
Posts: 1159
Joined: Sun Mar 23, 2003 8:38 pm
Location: New Orleans

Re: Archiving giving me a strange error

Postby Parahead » Fri Dec 10, 2004 1:44 pm

bozoka45 wrote:
Parahead wrote:And you have specified a Archive File Path for the Profile or a default archive file path under the general settings page?

Either method returns the error. If I change it to something besides single file then it works (month, day, week, etc).
OK, then it really looks like a bug in 1.30.8 for that archive type, maybe cerberos has an idea of why?
Yes, I am still around...
www.parahead.com/coranto/
User avatar
Parahead
 
Posts: 4837
Joined: Fri Jan 12, 2007 8:54 pm
Location: Stockholm - Sweden

Postby bozoka45 » Fri Dec 10, 2004 10:09 pm

Ok, thats what I thought. Would you mind moving this to the bug section, please?
User avatar
bozoka45
 
Posts: 1159
Joined: Sun Mar 23, 2003 8:38 pm
Location: New Orleans

Postby cerberos76_ » Fri Dec 10, 2004 10:44 pm

Not clear why this happens.
I wonder if this was present also in other previous 30.x versions or is only due to .8 changes... Will verify
Coranto addons:
* GuestPost, one click guestposting
* MoveIt!, Advanced Backup and site transfer
* PartialRebuild, CPU-friendly enhancement of FullBuild
* URLColumn, URLs for multiple Categories/Profiles
* Tickit!, Javascript News Tickers/Faders for Coranto!
* AddonEnabler, enables or disables single, multiple or all addons in one go
* SubmitMultiple, post consecutive news in an automatic loop!
* RSSAdvanced, RelatedNews ....

Get them at: http://coranto.gweilo.org/addons/
cerberos76_
 
Posts: 1339
Joined: Sun Mar 10, 2002 1:21 am

Postby bozoka45 » Fri Dec 10, 2004 11:07 pm

Is anyone able to reproduce this error?
User avatar
bozoka45
 
Posts: 1159
Joined: Sun Mar 23, 2003 8:38 pm
Location: New Orleans

Postby cerberos76_ » Sat Dec 11, 2004 9:43 pm

yes,
I can confirm it is a bug. I can reproduce it in 1.30.9.

I am tracing it now and will be solved in the new release I hope to put out soon. Will update on this

P.S.: I fixed the other small bug reported with fatal error given if you deleted an active addon. Now Coranto behaves much nicer also in that event
Coranto addons:
* GuestPost, one click guestposting
* MoveIt!, Advanced Backup and site transfer
* PartialRebuild, CPU-friendly enhancement of FullBuild
* URLColumn, URLs for multiple Categories/Profiles
* Tickit!, Javascript News Tickers/Faders for Coranto!
* AddonEnabler, enables or disables single, multiple or all addons in one go
* SubmitMultiple, post consecutive news in an automatic loop!
* RSSAdvanced, RelatedNews ....

Get them at: http://coranto.gweilo.org/addons/
cerberos76_
 
Posts: 1339
Joined: Sun Mar 10, 2002 1:21 am

Postby bozoka45 » Sun Dec 12, 2004 1:43 am

cerberos76 wrote:yes,
I can confirm it is a bug. I can reproduce it in 1.30.9.

I am tracing it now and will be solved in the new release I hope to put out soon. Will update on this

P.S.: I fixed the other small bug reported with fatal error given if you deleted an active addon. Now Coranto behaves much nicer also in that event


Great, thanks!
User avatar
bozoka45
 
Posts: 1159
Joined: Sun Mar 23, 2003 8:38 pm
Location: New Orleans

Postby cerberos76_ » Sun Dec 12, 2004 4:12 am

Bug traced down and solved. This was a bit hidden... well found.
I think it affected all 1.30.x series

If you wish to solve in your installation, open the file crcore.pl
around line 1701

find:
$FilesOpened{$key} = CRopen(">>$ProfFilePath{$key}/$newsprofiles{$key}->{'textfile'}");

$value = $FilesOpened{$key};


and change that into:
my $proffilepath=$ProfFilePath{$key};
my $openfilename=$newsprofiles{$key}->{'textfile'};

#check if it is an archive
if ($key =~ /(\S+)-archive$/) {
$proffilepath=$ProfArchiveFilePath{$1};
$openfilename="$key.txt";
}

$FilesOpened{$key} = CRopen(">>$proffilepath/$openfilename");

$value = $FilesOpened{$key};
Coranto addons:
* GuestPost, one click guestposting
* MoveIt!, Advanced Backup and site transfer
* PartialRebuild, CPU-friendly enhancement of FullBuild
* URLColumn, URLs for multiple Categories/Profiles
* Tickit!, Javascript News Tickers/Faders for Coranto!
* AddonEnabler, enables or disables single, multiple or all addons in one go
* SubmitMultiple, post consecutive news in an automatic loop!
* RSSAdvanced, RelatedNews ....

Get them at: http://coranto.gweilo.org/addons/
cerberos76_
 
Posts: 1339
Joined: Sun Mar 10, 2002 1:21 am

Postby bozoka45 » Sun Dec 12, 2004 10:18 am

cerberos, it seems that this new fix causes my Coranto version to "hang" and give me the server timeout error. I have tried a build and full build with and without the changes, and in single or monthly archive mode.

Without the changes, I either get news built like normal (monthly mode) or I get the error (the bug, if you will, in single file mode).

On the other hand, with the changes, I get a server timeout when the default news profile is set to single file. When the default news profile is set to monthly file, Coranto performs as it should.
User avatar
bozoka45
 
Posts: 1159
Joined: Sun Mar 23, 2003 8:38 pm
Location: New Orleans

Postby cerberos76_ » Sun Dec 12, 2004 5:46 pm

I cannot think to why this does not solve your problem.
I think that is the only change I made to the crcore and it solved the issue as it should in 1.30.9. I will release this new version pretty soon, so you will be able to try this new one.
Coranto addons:
* GuestPost, one click guestposting
* MoveIt!, Advanced Backup and site transfer
* PartialRebuild, CPU-friendly enhancement of FullBuild
* URLColumn, URLs for multiple Categories/Profiles
* Tickit!, Javascript News Tickers/Faders for Coranto!
* AddonEnabler, enables or disables single, multiple or all addons in one go
* SubmitMultiple, post consecutive news in an automatic loop!
* RSSAdvanced, RelatedNews ....

Get them at: http://coranto.gweilo.org/addons/
cerberos76_
 
Posts: 1339
Joined: Sun Mar 10, 2002 1:21 am

Postby bozoka45 » Sun Dec 12, 2004 10:50 pm

Well, it solves the problem of giving me an error, it just doesn't do ANYTHING this time :)

I'll wait for the next release.
User avatar
bozoka45
 
Posts: 1159
Joined: Sun Mar 23, 2003 8:38 pm
Location: New Orleans


Return to Coranto 2.0 Development

Who is online

Users browsing this forum: No registered users and 0 guests

cron