Internal Server Error

Is Coranto not working properly for you? Here's where to ask for support help; for best results, follow these steps:
  • - Check your core/addon documentation for possible solutions
  • - Search these forums for similar problems that have already been solved
  • - If you're still stumped, check out THIS TOPIC, and post your question in this forum!!

Moderators: Spunkmeyer, Dale Ray, SrNupsen, Bluetooth, Jackanape

Internal Server Error

Postby Jackdelamare » Mon May 05, 2008 6:00 pm

Hi,

I have just followed the steps to upload Coranto onto my server. I CHMOD'ed all the files that needed it, but when I go to www.delamarepro.com/fastballnews/coranto.cgi, it comes up with the following:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@delamarepro.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.37 Server at www.delamarepro.com Port 80


The path to my Perl seems to be just /perl/ but I am unsure and hopefully I'll be able to get some help.

Thanks in advance!
Jack De La Mare
De La Mare Productions
www.delamarepro.com
Jackdelamare
 
Posts: 3
Joined: Mon May 05, 2008 5:41 pm
Location: Guernsey, Channel Islands, UK

Postby Dale Ray » Mon May 05, 2008 6:59 pm

When I try the URL for your Coranto install that you gave I get a 404 error.

Read Internal Server Error at Parahed's site.

Try checking the path to perl. Are cgi scripts allowed outside the cgi-bin directory on your server?

Searching for the error message you got in the forums here will return other threads where the same problem is addressed.
Dale Ray
User avatar
Dale Ray
 
Posts: 1001
Joined: Sun Jan 19, 2003 6:02 pm
Location: NW Indiana

Postby Jackdelamare » Mon May 05, 2008 7:39 pm

I can't seem to get it to work. I followed the instructions given on that link you sent me, and nothing. When I uploaded them to my cgi-bin, it wouldn't let me in, so I scratched that idea.
When I enter my file manager, the "perl" folder is on it's own there, it's not in Public_Html or any other folder, it's just /perl/, so when I edit the two files at the beginning, it's right for me to just put "/perl" right?
Jack De La Mare
De La Mare Productions
www.delamarepro.com
Jackdelamare
 
Posts: 3
Joined: Mon May 05, 2008 5:41 pm
Location: Guernsey, Channel Islands, UK

Postby Dale Ray » Mon May 05, 2008 8:06 pm

Jack,

The path to perl is probably one of these:

#!/usr/bin/perl
#!/usr/local/bin/perl
#!/usr/sbin/perl
#!/usr/lib/perl

You might want to read this perl tutorial which I borrowed the above suggestions from.

Most hosting companies don't give users access to the perl install directory. The directory you are seeing may be used for uploading libraries that the user needs.

Access to the cgi-bin directory may need a different user account than the one you use for uploading html to the rest of your site. This is a question you will have to ask your hosting company. BTW, what hosting service are you using?

Is your server running some kind of unix or Windows?
Dale Ray
User avatar
Dale Ray
 
Posts: 1001
Joined: Sun Jan 19, 2003 6:02 pm
Location: NW Indiana

Postby Jackdelamare » Mon May 05, 2008 8:11 pm

Dale Ray wrote:BTW, what hosting service are you using?

Is your server running some kind of unix or Windows?


www.lc-hosting.com

Linux/Unix I believe. I usually have full access to everything.

I'll get back to you if the Perl path's work :).

EDIT: It's now fully working and it installed fine... thanks for the help. Now I've just got to work on getting it into my website.
Jack De La Mare
De La Mare Productions
www.delamarepro.com
Jackdelamare
 
Posts: 3
Joined: Mon May 05, 2008 5:41 pm
Location: Guernsey, Channel Islands, UK


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 3 guests

cron