Help with Feed Builder

Discuss news styles, css code, and other Coranto customizations in here...the possibilities are endless, so have at it!

Moderator: Spunkmeyer

Help with Feed Builder

Postby Cjkorf » Thu Jan 03, 2008 8:14 pm

Hi all, new to Coranto but really like what all it can do. Anyway, I downloaded the feed builder addon and I am having a lot of trouble setting it up. I am using Coranto version 1.25.1 and I just can't figure out what I need to do to get the script working. I've read all the documents that came with the download and also looked in the forum and that just left me more confused. Is there a step by step guide to setting up the styles and profiles needed? Thanks
Cjkorf
 
Posts: 12
Joined: Thu Jan 03, 2008 6:47 pm

Postby SrNupsen » Thu Jan 03, 2008 9:19 pm

I suggest you use this approach instead of the addon.
-----------------------------------------------------------------------------------------------------
Coranto is free software. I am available for custom work or troubleshooting.

http://www.sundaune.no - transkripsjon, webdesign, nettsider, tekstbyrå
http://www.vagbladet.no - satire, politikk, kultur, sport, nettavis
-----------------------------------------------------------------------------------------------------
SrNupsen
 
Posts: 2229
Joined: Tue Jan 09, 2007 6:46 pm
Location: Nesodden, outside Oslo, Norway

Postby Cjkorf » Thu Jan 03, 2008 10:19 pm

Thanks for the quick reply. I tried all that and I now when I go to my rss.xml (http://www.chiefswarpath.com/news/rss.xml) page it reads:

The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


--------------------------------------------------------------------------------

Only one top level element is allowed in an XML document. Error processing resource 'http://www.chiefswarpath.com/news/rss....

<link>http://www.chiefswarpath.com/home.htm</link>
-^



Any ideas on what's wrong?
Cjkorf
 
Posts: 12
Joined: Thu Jan 03, 2008 6:47 pm

Postby Cjkorf » Thu Jan 03, 2008 10:36 pm

I'm not even sure where the home.htm is coming from. It's not in my profile or style for the feed. I'm also using Maginot to make static pages. Would that have anything to do with it?
Cjkorf
 
Posts: 12
Joined: Thu Jan 03, 2008 6:47 pm

Postby Musicvid » Thu Jan 03, 2008 10:45 pm

hold on a minute, I'll answer both questions.
Musicvid
 
Posts: 138
Joined: Wed Jan 17, 2007 1:05 am
Location: Western America

Postby Musicvid » Thu Jan 03, 2008 10:51 pm

The .xml declaration is missing from the top of the document. This means it is not going through rss.tmpl

Check the html template specified in your RSS_Feed Profile. You must upload and use rss.tmpl -- viewnews. tmpl will not work.

The feed style was developed for Coranto 1.3x. If you are using 1.25 you will need to use this addon to rename the file:
http://www.corantodemo.net/coranto/view ... =dldetails

As far as the link url, it is currently taken from your "Site Link" in "Change Settings" in the Coranto Admin. This will change in the next versions. I don't think this was the cause of your problem though, the feed is invalid without the xml declaration line.

Hope this helps!
Musicvid
 
Posts: 138
Joined: Wed Jan 17, 2007 1:05 am
Location: Western America

Postby Cjkorf » Thu Jan 03, 2008 11:07 pm

Thanks for the replies. I've got to go for a while, but I'll try it all tomorrow.
Cjkorf
 
Posts: 12
Joined: Thu Jan 03, 2008 6:47 pm

Postby Cjkorf » Fri Jan 04, 2008 6:17 am

Ok, got it downloaded. So now I need to change the extension on the RSS_Feed profile to xml correct?
Cjkorf
 
Posts: 12
Joined: Thu Jan 03, 2008 6:47 pm

Postby Musicvid » Fri Jan 04, 2008 4:21 pm

That's my understanding, it will allow you to name the extension of the "HTML User File Name" in your RSS Profile to .xml.

I'm using version 1.31.5 which doesn't need this, but others report it works fine with older versions.

BTW nice site, even though I am a Broncos fan . . .
Musicvid
 
Posts: 138
Joined: Wed Jan 17, 2007 1:05 am
Location: Western America

Postby Cjkorf » Fri Jan 04, 2008 4:32 pm

Oh no, not the Broncos. Thanks for the compliment on the site. I think I've pretty much got it working now. I was trying to go to http://www.chiefswarpath.com/news/rss.xml but it appears the correct link is http://www.chiefswarpath.com/news/RSS_Feed.xml .

The only think now is the links to the stories in the feed aren't working. I assume it has something to do with the RSS Feed style. See if I can figure it out.
Last edited by Cjkorf on Fri Jan 04, 2008 6:10 pm, edited 1 time in total.
Cjkorf
 
Posts: 12
Joined: Thu Jan 03, 2008 6:47 pm

Postby Cjkorf » Fri Jan 04, 2008 5:49 pm

For some reason when I try and click on a story from the RSS feed it is putting a %22%3E on the end of each url.

http://www.chiefswarpath.com/news/01/04 ... .htm%22%3E

instead of

http://www.chiefswarpath.com/news/01/04 ... istake.htm
Cjkorf
 
Posts: 12
Joined: Thu Jan 03, 2008 6:47 pm

Postby Musicvid » Fri Jan 04, 2008 10:22 pm

Looks like you're almost there --
for some reason it's adding "> at then end of the item url as if it came from some orphan html. Since it looks like your Item <link> code is pointing to the maginot file rather than viewnews.cgi, see if you can find out where this extra stuff is coming from. Since I'm not using maginot I don't how where to direct you beyond this. Should be easy for someone to help you with, though.

Perhaps if you post your style code from <item> to </item> below the end of the PerlCode it will help.

I just noticed: The link is correct in your item <guid>
Change the item <link> attribute to match it and you should have your problem solved.
Musicvid
 
Posts: 138
Joined: Wed Jan 17, 2007 1:05 am
Location: Western America

Postby Cjkorf » Sat Jan 05, 2008 4:08 am

I don't think the <guid> link is right either. Funny, when I view the source the links appear alright.

Anyway, here's what I have between <item> and </item>

<title><![CDATA[<Field: Subject>]]></title>
<link><![CDATA[<MaginotURL: maginotnews>">]]></link>
<description><![CDATA[<Snip 265: Field: Text>]]></description>
<pubDate><Field: pubDate></pubDate>
<guid isPermaLink="true"><MaginotURL: maginotnews></guid>

I've tried everything I can think of and still no luck.
Cjkorf
 
Posts: 12
Joined: Thu Jan 03, 2008 6:47 pm

Postby Musicvid » Sat Jan 05, 2008 4:20 am

Yes, you have put the extra characters "> in the <link> attribute. Take them out and all will work right. Those characters are not in the original code for the style. I have highlighted them so you will know exactly which characters to take out. Yes, the guid url works and so will all the links once you take out the extraneous characters.
Anyway, here's what I have between <item> and </item>

<title><![CDATA[<Field: Subject>]]></title>
<link><![CDATA[<MaginotURL: maginotnews>">]]></link>
<description><![CDATA[<Snip 265: Field: Text>]]></description>
<pubDate><Field: pubDate></pubDate>
<guid isPermaLink="true"><MaginotURL: maginotnews></guid>
Musicvid
 
Posts: 138
Joined: Wed Jan 17, 2007 1:05 am
Location: Western America

Postby Cjkorf » Sat Jan 05, 2008 5:07 am

It worked! Thanks for all your help, I really appreciate it.
Cjkorf
 
Posts: 12
Joined: Thu Jan 03, 2008 6:47 pm

Next

Return to Customization

Who is online

Users browsing this forum: No registered users and 1 guest

cron